# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\\/p>\n\n<p>//g;t' <<< "<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>"