import Foundation
let pattern = #"<\/p>\n\n<p>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)