using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/p>\n\n<p>";
string substitution = @"";
string input = @"<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}