re = /<\/p>\n\n<p>/
str = '<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result