import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/p>\\n\\n<p>";
final String string = "<p>This is a test of a </p>\n\n"
+ "<p>long sentence that</p>\n\n"
+ "<p>should not be separated.</p>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}