package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\/p>\n\n<p>`)
var str = `<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}