$re = '/<\/p>\n\n<p>/';
$str = '<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;