const regex = /<\/p>\n\n<p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/p>\\n\\n<p>', 'g')
const str = `<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);