import re
regex = re.compile(r"<\/p>\n\n<p>")
test_str = ("<p>This is a test of a </p>\n\n"
"<p>long sentence that</p>\n\n"
"<p>should not be separated.</p>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)