# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)__P\((.*?)\);/\1\2;/gs;t' <<< "char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));"