import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)__P\\((.*?)\\);";
final String string = "char *x __P((char *, size_t,\n"
+ " void *, size_t, int));\n"
+ "char *y __P((void *, const char *, int));";
final String subst = "\\1\\2;";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}