use strict;
my $str = 'char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));';
my $regex = qr/(.*?)__P\((.*?)\);/sp;
my $subst = '\\1\\2;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";