import Foundation
let pattern = #"(.*?)__P\((.*?)\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)