package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(.*?)__P\((.*?)\);`)
var str = `char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));`
var substitution = "\1\2;"
fmt.Println(re.ReplaceAllString(str, substitution))
}