$re = '/(.*?)__P\((.*?)\);/s';
$str = 'char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));';
$subst = "\1\2;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;