// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(.*?)__P\((.*?)\);").unwrap();
let string = "char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));";
let substitution = "\\1\\2;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}