re = /(.*?)__P\((.*?)\);/
str = 'char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));'
subst = '\\1\\2;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result