#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(.*?)__P\((.*?)\);"
Local $sString = "char *x __P((char *, size_t," & @CRLF & _
" void *, size_t, int));" & @CRLF & _
"char *y __P((void *, const char *, int));"
Local $sSubst = "\1\2;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)