const regex = /(.*?)__P\((.*?)\);/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)__P\\((.*?)\\);', 'gs')
const str = `char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));`;
const subst = `\1\2;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);