using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)__P\((.*?)\);";
string substitution = @"\1\2;";
string input = @"char *x __P((char *, size_t,
void *, size_t, int));
char *y __P((void *, const char *, int));";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}