# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)__P\((.*?)\);"
test_str = ("char *x __P((char *, size_t,\n"
" void *, size_t, int));\n"
"char *y __P((void *, const char *, int));")
subst = "\\1\\2;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.