# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*rpc (\w+).*/rpc $1(Service$1Request) returns (Service$1Response) {}/mg;t' <<< " rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend"