use strict;
my $str = ' rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend';
my $regex = qr/^\s*rpc (\w+).*/mp;
my $subst = 'rpc $1(Service$1Request) returns (Service$1Response) {}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";