re = /^\s*rpc (\w+).*/m
str = ' rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend'
subst = 'rpc $1(Service$1Request) returns (Service$1Response) {}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result