const regex = /^\s*rpc (\w+).*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*rpc (\\w+).*', 'mg')
const str = ` rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend`;
const subst = `rpc $1(Service$1Request) returns (Service$1Response) {}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);