// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*rpc (\w+).*").unwrap();
let string = " rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend";
let substitution = "rpc $1(Service$1Request) returns (Service$1Response) {}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}