package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*rpc (\w+).*`)
var str = ` rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend`
var substitution = "rpc $1(Service$1Request) returns (Service$1Response) {}"
fmt.Println(re.ReplaceAllString(str, substitution))
}