import re
regex = re.compile(r"^\s*rpc (\w+).*", flags=re.MULTILINE)
test_str = (" rpc Ammend\n"
" rpc Cancel\n"
" rpc Copy\n"
" rpc Suspend")
subst = "rpc $1(Service$1Request) returns (Service$1Response) {}"
result = regex.sub(subst, test_str)
if result:
print(result)