import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*rpc (\\w+).*";
final String string = " rpc Ammend\n"
+ " rpc Cancel\n"
+ " rpc Copy\n"
+ " rpc Suspend";
final String subst = "rpc $1(Service$1Request) returns (Service$1Response) {}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}