using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*rpc (\w+).*";
string substitution = @"rpc $1(Service$1Request) returns (Service$1Response) {}";
string input = @" rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}