import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s^a-zA-Z0-9&\\'\\\"\\s+]', ''";
final String string = "dau d dausadasd\n"
+ " sdasf sd\n\n"
+ "dasd\n"
+ "asf\n";
final String subst = "+32 india Country";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}