use strict;
my $str = 'dau d dausadasd
sdasf sd
dasd
asf
';
my $regex = qr/[\s^a-zA-Z0-9&\'\"\s+]', ''/ip;
my $subst = '+32 india Country';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";