// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)[\s^a-zA-Z0-9&\'\"\s+]', ''"#).unwrap();
let string = "dau d dausadasd
sdasf sd
dasd
asf
";
let substitution = "+32 india Country";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}