re = /[\s^a-zA-Z0-9&\'\"\s+]', ''/i
str = 'dau d dausadasd
sdasf sd
dasd
asf
'
subst = '+32 india Country'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result