# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*[^\t\s]=[^\t\s].*
/ = /g;t' <<< "x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something"