using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[^\t\s]=[^\t\s].*
";
string substitution = @" = ";
string input = @"x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}