import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[^\\t\\s]=[^\\t\\s].*\n";
final String string = "x=something\n"
+ "if(y==x)\n"
+ "if(y <=x)\n"
+ "if(y>=x)\n"
+ "if(y!=x)\n"
+ "x = something\n"
+ "x=something\n"
+ "x = something";
final String subst = " = ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}