// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*[^\t\s]=[^\t\s].*
").unwrap();
let string = "x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something";
let substitution = " = ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}