const regex = new RegExp('.*[^\\t\\s]=[^\\t\\s].*
', 'g')
const str = `x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something`;
const subst = ` = `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);