import re
regex = re.compile((r".*[^\t\s]=[^\t\s].*\n"))
test_str = ("x=something\n"
"if(y==x)\n"
"if(y <=x)\n"
"if(y>=x)\n"
"if(y!=x)\n"
"x = something\n"
"x=something\n"
"x = something")
subst = " = "
result = regex.sub(subst, test_str)
if result:
print(result)