re = /.*[^\t\s]=[^\t\s].*
/
str = 'x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something'
subst = ' = '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result