package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*[^\t\s]=[^\t\s].*
`)
var str = `x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something`
var substitution = " = "
fmt.Println(re.ReplaceAllString(str, substitution))
}