# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[A-Za-z](?:[\s\S]*?[^\\]$)?/<pre>$0<\/pre>/gm;t' <<< "npm i --save \
gulp \
express \
forever
echo hi
a"