$re = '/^[A-Za-z](?:[\s\S]*?[^\\\\]$)?/m';
$str = 'npm i --save \\
gulp \\
express \\
forever
echo hi
a';
$subst = "<pre>$0</pre>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;