import re
regex = re.compile(r"^[A-Za-z](?:[\s\S]*?[^\\]$)?", flags=re.MULTILINE)
test_str = ("npm i --save \\\n"
"gulp \\\n"
" express \\\n"
" forever\n\n\n"
"echo hi\n"
"a")
subst = "<pre>$0</pre>"
result = regex.sub(subst, test_str)
if result:
print(result)