import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z](?:[\\s\\S]*?[^\\\\]$)?";
final String string = "npm i --save \\\n"
+ "gulp \\\n"
+ " express \\\n"
+ " forever\n\n\n"
+ "echo hi\n"
+ "a";
final String subst = "<pre>$0</pre>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}