re = /^[A-Za-z](?:[\s\S]*?[^\\]$)?/m
str = 'npm i --save \\
gulp \\
express \\
forever
echo hi
a'
subst = '<pre>$0</pre>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result