import Foundation
let pattern = #"^[A-Za-z](?:[\s\S]*?[^\\]$)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
npm i --save \
gulp \
express \
forever
echo hi
a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<pre>$0</pre>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)