# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'.*?' id='phone\$1'>.*?</'customer' id='phone\$1'>Organization</g;t' <<< "<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>"