$re = '/\'.*?\' id=\'phone\$1\'>.*?</';
$str = '<div>
<span class=\'customer\' id=\'phone$0\'>Home</span>
<br/>
<span class=\'customer\' id=\'phone$1\'>Business</span>
<br/>
<span class=\'customer\' id=\'phone$2\'>Mobile</span>
</div>';
$subst = "'customer' id='phone\$1'>Organization<";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;